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История вопроса
Работая со студентами мне не редко приходится читать их дипломные и курсовые работы, 
вносить в них исправления, а затем редактировать новые и новые версии. Составляя отчеты и 
при написании статей мне также приходится работать над одним документом с несколькими 
людьми. Не редко я сталкивался с тем, что приходит по почте документ, в котором цветом 
помечен текст. Потом звонит человек, который говорит, что он имел в виду, когда этот текст 
отмечал.  Повторно проверяя работы студентов я нередко задавал вопрос о том,  что было 
поправлено  в  тексте,  поскольку  согласитесь  читать  занов  десятки  страниц  текста  нет 
никакого  желания,  а  чаще еще времени.  В конечном итоге  пришла идея  создать  учебное 
пособие  о  том  какие  есть  инструменты  и  какие  они  предоставляют  возможности  по 
совместной работе с текстовыми документами.

Надеюсь вы найдете данный материал полезным.

Что такое совместная работа
Под совместной работой будем понимать возможность нескольких человек работать с одним 
текстовым документом. При этом должна быть возможность отслеживать все сделанные в 
документе изменения и (опционально) возврат к одной из предыдущих версий.

Совместная работа может быть организована по разному, но чаще всего это происходит так. 
Кто-то пишет какой-то документ, потом распечатывает его и отдает другому человеку. Второй 
маркером  помечает  текст  красным,  желтым  или  зеленым  цветом,  дописывает  свои 
комментарии и возвращает черновики на доработку.  С приходом сети интернет документы 
меньше стали печатать, но в целом процесс остался тем же. Современные средства работы с 
текстовой информацией представляют существенно больше возможностей, которые и будут 
рассмотрены далее.

Форматы текстовых документов позволяют организовать совместную работу с текстовыми 
документами следующим образом:

1. Сделать  документ составным.  Создать,  так  называемый,  мастер  документ,  который 
будет объединять несколько других документов.  Составные части документа могут 



редактироваться независимо друг от друга и в этом плане получается полноценная 
совместная  работа.  Например  при  написании  научно-технического  отчета  кто-то 
пишет введение и заключение, кто-то аналитический обзор в отчете, кто-то еще какие-
то  главы.  Имея  все  части  и  мастер-документ  можно  всегда  посмотреть  текущую 
версию документа.

2. Каждый  их  документов  составного  документа  так  же  может  редактироваться 
несколькими  людьми.  Для  этого  во  многих  форматах  текстовых  документах 
предусмотрена  возможность  отслеживать  и  протоколировать  сделанные  изменения, 
делать пометки на полях.

3. Третий  вариант  систем  позволяет  редактировать  документ  прямо  в  сети  так  же 
отслеживая все изменения, сделанные пользователями.

4. Существуют и промежуточные варианты, когда документ редактируется локально на 
компьютере, а храниться в сети и там же отслеживаются все изменения.

Рассмотрим наиболее часто встречающиеся системы.

Средства 

OpenOffice Writer
В OpenOffice Writer обладает большими возможностями по совместной работе. Его можно 
отнести  к  первому и  второму пункту из  вышеупомянутых.  Рассмотрим  эти  возможности 
поподробнее.

Составной документ
Для создания мастер-документа необходимо выбрать File->New->Master Document

Аналогично мастер-документ можно создать через панель инструментов.



После того, как мастер-документ создан, с ним можно работать как с обычным документом, 
т.е. писать в нем текст, его форматировать и т.д. Особенностью мастер-документа является то, 
что  к  нему  можно  прикреплять  другие  документы.  В  мастер-документе  хранятся  только 
ссылки на них. Работа с документом происходит через панель «Navigator».

По двойному щелчку можно переходить на редактирование прикрепленного файла. После 
редактирования и сохранения мастер-документ нужно обновить.

Помимо удобства совместной работы над документом, использование составных документов 
дает преимущество при работе с большими документами экономя драгоценную оперативную 
память компьютера. Естественно, что здесь я имею в виду документы не на десяток страниц.

В мастер-документе можно редактировать только ту часть текста, которая в нем же и была 
набрана.  Все  под-документы открываются  в  режиме «только  на  чтение».  Прикрепленные 
под-документы при необходимости по одному щелчку мыши могут быть перемещены вверх 
или вниз по основному документу.



Окончательный документ может быть сохранен в одном файле в формате ODT или PDF  
(File-> Export->Portable Document Format).

Изменения в документе и комментарии к нему
Чтобы в редактируемом документе остались данные о том, кто его редактировал, необходимо 
чтобы  корректный  данные  были  указаны  в  настройках  OpenOffice.  Информация  о 
пользователе редактором задается в панели «Options», которая вызывается через меню Tools 
(Tools -> Options...). Далее во вкладке «User data» в ветке «OpenOffice.org» следует правильно 
указать свои имя и фамилию.

Комментарии  к  тексту  можно  вставлять  прямо  в  текс,  но  в  таком  случае  вам  придется 
помечать из еще и цветом, чтобы они были заметны другим авторам. На мой взгляд более 
красивый способ написать комментарии к тексту — сделать заметки на полях.  Для этого 
необходимо поставить курсор в начало того текста, к которому пишется примечание и в меня 
«Insert» выбирается пункт «Comment» (или можно нажать Alt+Shift+N).

Включить запись изменений в документ можно через меню Edit -> Changes -> Record. В той 
же вкладке можно включить и выключить отображение изменений.  Работать с текстом с 
включенным режимом отображения изменений не очень-то удобно, но иногда и он бывает 
полезным, когда надо посмотреть кто и что в документе исправил.



Собственно при сравнении двух документов редактор разницу в документах записывает в 
виде изменений.

Пояснения к изменениям всплывают при наведении курсора на текст.

Сделанные в тексте изменения перед сохранением окончательной версии документа можно 
принять или отклонить. Для этого надо вызвать контекстной меню, щелкнув правой кнопкой 
мыши по изменению и выбрать «Accept  Changes» или «Reject  Changes».  Альтернативный 
вариант — вызвать диалоговое окно «Accept or Reject Changes» (Edit -> Changes -> Accept or 
Reject...).



В этом диалоговом окне можно к каждому изменению добавить комментарий. Это можно 
сделать  и  через  меню (Edit  ->  Changes  ->  Comment).  Комментарий будет  отображаться  в 
подсказке под именем того, кто это изменение сделал.

Если изменений много, то их можно отфильтровать по дате, автору и\или типу изменения.

Соответственно  выбрав  и  отменив  все  изменения,  сделанные  на  какую-то  дату,  можно 
вернуться к предыдущей версии документа.

Есть, конечно, несколько более удобный способ возврата к предыдущей версии документа — 
хранить его версии. Можно настроить OpenOffice Writer так, что каждый раз при закрытии 
документа будет запоминаться новая его версия. При этом все версии хранятся в одном файле 
в виде записи изменений. Таким образом возврат к одной из предыдущих версий становится 
делом двух щелчков мыши и плюс есть возможность сравнивать две версии друг с другом.



Работа с версиями происходит в диалоговом окне «Versions of ...» (File -> Versions).

В представленном диалоговом окне кнопка «Open» позволяет открыть выбранную версию 
документа или в режиме «только на чтение» или сделать копию документа и открыть ее для 
редактирования.  Кнопка  «Delete»  удаляет  выбранную  версию,  а  «Compare»  -  показывает 
изменения сделанные в текущей версии.

Дополнительно  можно  порекомендовать  в  начале  документа  делать  таблицу,  в  которую 
вносить дату модификации документа, автора изменений и что поменялось в документе.

MS Word
Программа  MS  Word  (будем  говорить  о  версии  MS  Word  2007)  предоставляет  теже 
возможности  по  совместной  работе  над  документом,  что  и  OpenOffice  Writer.  При 
использовании дополнительных программ от Microsoft (например, SharePoint Portal Server) 
эти возможности могут быть несколько расширены. Однако в большинстве случаев затраты 
на создание инфраструктуры больше выгоды, получаемой от дополнительных возможностей.

Для объединения нескольких документов в один в MS Word нет необходимости создавать 
специальный мастер документ.  Под-документы можно вставлять в обычный файл. Для этого 
надо  переключиться  в  режим просмотра  структуры  документа  выбрав  во  вкладке  «Вид» 
режим отображения «Структура».

Затем во вкладке «Структура» выбрать «Показать документ» (кнопка замениться на кнопку 
«Главный документ»).  Нажатием на  новую кнопку открывается  панель,  в  которой можно 
выбрать  вставку  существующего  файла  в  текущую  позицию,  или  создание  вложенного 
документа. Возможны и другие действия.



MS Word позволяет вставлять примечания и отслеживать сделанные изменения в документе.

Все эти действия производятся через вкладку «Рецензирование». Для большинства действий 
в  MS  Word  предусмотрены  сочетания  клавиш,  но,  например,  заявленное  Alt+Ctrl+M  для 
вставки примечания на моем компьютере почему-то не работало. Просматривать документ 
можно как исходный (без исправлений), так и итоговый (без подсветки изменений).

Информация об авторе вносимых в текст исправлений задается в свойствах документа.

Для  сравнения  документов  в  MS  Word  предусмотрено  два  варианта:  визуальный  и 
автоматический  с  отображением разницы в  документах  в  виде  исправлений.  Визуальный 
режим  предполагает,  что  пользователь  располагает  два  документа  рядом  и  при 
прокручивании текста в одном окне происходит синхронное прокручивание текста во втором 
открытом окне. Для перехода в этот режим необходимо открыть два документа и во вкладке 
«Вид» выбрать способ отображения «Рядом». Синхронная прокрутка при этом включается 
автоматически.

Второй  вариант  автоматизирован  и  является  более  традиционным.  Во  вкладке 
«Рецензирование»  необходимо  выбрать  «Сравнить»  два  документа  и  в  появившемся 
диалоговом  окне  указать  что  с  чем  сравнивать.  При  этом  можно  сравнивать  как  уже 
открытый документ, так и неоткрытый.



Сохранение различных версий в документе MS Word видимо не предусмотрено, поскольку 
для этого разработчики предполагают использовать MS SherePoint Portal Server.

Google Docs
Совместная  работа  над  документом  в  Google  Docs  в  чем-то  проще,  чем  в  редакторах, 
описанных выше. Собственно это является и преимуществом, и в тоже время не позволяет 
сделать некоторые из описанных выше действий (например, делать составные документы). 
Но обо всем по порядку. 

Google  Docs  —  это  приложение  в  сети,  доступное  через  веб-браузер.  Поскольку 
редактируемый документ сохраняется на сервере, то он доступен всем пользователям, между 
которыми он разделяется. На рисунке табличный файл «Conferences» открыт для совместной 
работы с  еще одним человеком.  Для совместной работы файл  можно отдавать  только на 
чтение или для редактирования.



Из левой панели видно,  что  файлы можно отбирать  по владельцу (принадлежат мне или 
только открыты для совместной работы), по типу файла или по какому-то другому критерию.

Над выбранным файлом можно сделать несколько действий (аналогичное контекстное меню 
появиться  если  по  файлу  щелкнуть  правой  кнопкой  мыши):  сменить  владельца, 
экспортировать для сохранения локально (PDF, Open Document Format и пр.), просмотреть 
версии (Revisions), посмотреть информацию о файле (Show details).

Каждый раз при сохранении документа сохраняется его новая версия и информация о том, 
кто  этот  документ  редактировал.  Редактировать  документ  может  только  пользователь, 
который  имеет  учетную  запись  в  почте  Google.  Впрочем,  документ  можно  отдать  в 
публичное  пользование  всем пользователям сети  интернет,  но  зачем вам это  надо?   При 
выборе действия «просмотреть изменения» открывается список сделанных изменений: кто 
внес изменения и когда. Различные версии документов можно сравнить между собой.

При редактировании документа в него можно вставить комментарий.



LaTeX
Технология создание документов в LaTeX отличается от представленных выше. LaTeX не 
является  текстовым  редактором.  LaTeX  —  это  специальный  язык  и  система  подготовки 
документов.  Другими  словами  в  текстовом  файле  с  помощью  специальных  команд 
описывается  документ  и  как  он  должен  быть  отформатирован.  Затем  этот  документ 
компилируется и на выходе получается документ в формате DVI, который затем может быть 
преобразован в PS или PDF. Преимущество LaTeX-а в том, что после компиляции документ 
одинаково будет отображаться на любом компьютере и любой ОС, в отличие от документа, 
скажем,  в  формате  DOC.  Кроме  того  его  очень  любят  математики  часто  набивающие 
формулы, которые в том же MS Word или OO Writer не всегда наберешь. Да и набирать текст 
можно в FAR-е или Notepad.

LaTeX документ может содержать  комментарии и состоять  из  нескольких файлов.  В нем 
можно делать заметки на полях, а вот все остальные действия по совместной работе придется 
делать  с  помощью внешних программ.  Например,  различные версии документа  придется 
сохранять в отдельных файлах, а изменения смотреть через утилиту diff или fc (File compare). 

C:\Temp> fc back\book.tex right\book.tex
Comparing files BACK\book.tex and RIGHT\BOOK.TEX
***** BACK\book.tex
\usepackage{eurosym}
\usepackage{titlesec}
***** RIGHT\BOOK.TEX
\usepackage{eurosym}
\usepackage{amssymb}
\usepackage{titlesec}
*****

***** BACK\book.tex
\usepackage{textcomp}

***** RIGHT\BOOK.TEX
\usepackage{textcomp}
\usepackage{longtable}
\usepackage{rotating}
\usepackage{lscape}

*****
...



Возможно, что в каких-нибудь других программах эта информация будет выглядеть более 
наглядно. 

...
\begin{document} 
\include{titlepage} % подразумевается «titlepage.tex»
\include{introduction}
\include{preface}
\include{stimulus}
% data files with responds on stimulus
\include{_l_a}
\include{_l_b}
...

Стоит отметить, что в документ в виде отдельных файлов можно вставлять не только другие 
текстовые документы, но и картинки в разных форматах.

Вставка примечания на границе страницы происходит с помощью команды \marginpar.

Текст  в  документе  можно  выделять  цветом.  На  мой  взгляд,  эта  функция,  равно  как  и 
примечания  на  полях,  для  подавляющего  количества  создаваемых  документов  смысла  не 
имеет.

SVN
SVN — система  контроля  и  управления  версиями документов.  В  основном используется 
разработчиками программ, но с тем же успехом может применяться и для хранения LaTeX 
документов.  Система  устанавливается  на  сервер  и  с  помощью  клиентской  программы, 
которая может встраиваться в проводник, на сервер можно помещать документы, скачивать с 
сервера  необходимые  версии  документов,  просматривать  какая  информация  и  кем  была 
модифицирована.
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